Re: Needing help to use Sane over Network Client

From: Henning Meier-Geinitz (hmg-ml@gmx.de)
Date: Sun Dec 31 2000 - 14:30:19 PST

  • Next message: Nick Lamb: "Re: Installation and man page of find-scanner"

    Hi,

    On Sun, Dec 31, 2000 at 09:58:20PM +0000, Marek Walther wrote:
    > The problem is the network connect with the net backend, an the
    > serverkonsole work scanimage -L
    >
    > device `epson:/dev/usbscanner` is a Epson Perfecton1200 flatbed scanner
    >
    > Im missing the net:localhost:epson:/dev/scanner
    [...]
    > > > ec 31 17:12:51 chaosland saned[18820]: access by root@(null) rejected
    > > ^^^^^^^^^^^
    > >
    > > Your client wasn't allowed to use saned. Maybe there are also problems
    > > with anme-resolution (the "(null)" looks suspicous).
    >
    > this is my Problem

    To locate the exact source of the problem you can start saned without
    inetd/xinetd. Disable it in xinetd and start it directly (you have to
    restart it after every connect in this debug mode):

    /usr/local/sbin/saned -d128 &

    Now try scanimage -L. If it works, there is probably a problem with
    xinetd. Otherwise check if both hosts have their names and ip
    addresses in both /etc/hosts files (or DNS).

    Bye,
      Henning

    --
    Source code, list archive, and docs: http://www.mostang.com/sane/
    To unsubscribe: echo unsubscribe sane-devel | mail majordomo@mostang.com
    



    This archive was generated by hypermail 2b29 : Sun Dec 31 2000 - 14:14:37 PST