Re: Epson Backend - The Millenium Release

From: Karl Heinz Kremer (
Date: Mon Feb 21 2000 - 06:30:13 PST

  • Next message: Karl Heinz Kremer: "Re: Epson Backend - The Millenium Release"


    is the G7000 known by any other name? Is it possible that this is
    the GT-7000 (or Perfection 636)? If that's the case then it
    really should work. This is the scanner that Christian used to
    implement the TPU stuff. I don't have access to a TPU, so I
    can not test this myself.

    If you can provide log files I should however be able to figure
    out what's wrong.

    To turn on logging you have to set an environment variable:
    export SANE_DEBUG_EPSON=128
    This will log _EVERYTHING_ - every byte going from the scanner
    to the backend and the other direction are written to a file,
    so be careful when you set the resolution. Try to limit this to
    50 dpi scans. If the scanner never start to send data however this
    is not a problem.

    BTW: Which version of the EPSON backend are you using?

    This is all under the assumption that your scanner is the
    Perfection 636 (or GT-7000). There are problems with the TPU
    with the Perfection 1200, Epson changed something in the comamnd
    set and I'm still trying to figure out if I can get away without
    having to implement all the new commands.

    Karl Heinz

    Lars Burgstahler <> said:

    > Hi,
    > this weekend I found Karl Heinz' mail in the archive and downloaded
    the updated
    > backend. However, even if he states, that the TPU is supported, I
    cannot use it
    > on my Epson G7000-photo (SCSI).
    > I have Sane 1.0.1 and I'm using the latest xsane. When I turn on the
    TPU and
    > try to scan I get a message like "Invalid parameter". Does anybody
    > Heinz?) know why it doesn't work?
    > BTW, I'm willing to look for the error myself, but I didn't manage
    to turn the
    > debugging on. There's some DBG macro which I'm not able to use. How
    do I have
    > to compile the sources or where do I have to make modifications to
    get the
    > debugging messages? And where are they put to? I just didn't find
    > thank you, lars
    > --
    > Lars Burgstahler
    > Institute of Communication Networks and Computer Engineering
    > University of Stuttgart, Pfaffenwaldring 47, 70569 Stuttgart,
    > Tel: (+49) 711 685 7966 Fax: (+49) 711 685 7983
    > E-Mail:
    > --
    > Source code, list archive, and docs:
    > To unsubscribe: echo unsubscribe sane-devel | mail


    -- Source code, list archive, and docs: To unsubscribe: echo unsubscribe sane-devel | mail

    This archive was generated by hypermail 2b29 : Mon Feb 21 2000 - 06:29:25 PST