Compiling with gimp 1.1.14 libraries

Date: Mon Jan 17 2000 - 23:13:14 PST

  • Next message: Bill Wohler: "Re: Compiling with gimp 1.1.14 libraries"

    Is there a hack to get sane + xscanimage compile with latest
    development gimp?

    make[1]: Entering directory `/usr/local/src/sane-1.0.1/frontend'
    gcc -c -DHAVE_CONFIG_H -I. -I. -I../include -I../include -I/usr/local/include -I/usr/X11R6/include -I/usr/lib/glib/include -D_GNU_SOURCE -DPATH_SANE_CONFIG_DIR=/usr/local/etc/sane.d -DPATH_SANE_DATA_DIR=/usr/local/share -DV_MAJOR=1 -DV_MINOR=0 -g -O2 -Wall xscanimage.c
    xscanimage.c:79: conflicting types for `GIMP_EXTENSION'
    /usr/local/include/libgimp/gimpenums.h:289: previous declaration of `GIMP_EXTENSION'
    make[1]: *** [xscanimage.o] Error 1

    Search on Deja revealed a couple of messages about this, but they were
    both in German ;^|


    Arcady Genkin                       
    "'What good is my pity? Is not the pity the cross upon which he who
    loves man is nailed?..'" (Zarathustra - F. Nietzsche)

    -- Source code, list archive, and docs: To unsubscribe: echo unsubscribe sane-devel | mail

    This archive was generated by hypermail 2b29 : Mon Jan 17 2000 - 23:10:37 PST